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SOME EXAMPLES OF GPS DEVICES FOR DATA COLLECTION

BEST PRACTICES FOR GEOLOCATION DATA
COLLECTION AND PREPARATION

Smartphone TabletGPS Device

WHAT IS THIS GUIDE FOR?

Support SPOs in collecting and preparing geolocation data to:

While Fairtrade accepts remotely collected data, we recommend field data collection,
especially for polygon mapping of plots over 4 hectares or in high-risk areas. This guide
outlines best practices for accurate field data collection and submission to Fairtrade
International.

Important Note

HOW THIS GUIDE IS STRUCTURED

GPS PolygonsGPS Points

This guide provides instructions on how to collect,
prepare, and submit geolocation data in either point

or polygon format.

Ensure geolocation data meets Fairtrade standards.
Check for deforestation risks in mapped areas.
Format geolocation data to comply with EUDR rules.
Facilitate easy sharing of geolocation data with commercial partners.
Support transparency and trust in supply chains.
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PLAN YOUR DATA COLLECTION IN THE FIELD

Define whether plots will be mapped as points or polygons; for plots of more than
4 hectares and in high-risk areas, polygon mapping is required.
Assign unique and permanent identification codes to each farmer (farmer ID).
Make sure your team is prepared and understands how and what data should be
collected.
Plan each collection visit by identifying how many farms and plots will be visited
or how many hectares need to be covered.

Select GPS and GIS tools that meet data requirements and suit your resources.

1.GPS (Global Positioning System): A GPS device determines your position on Earth,
allowing you to collect precise location data. Smartphones and tablets with GPS
functionality can also be used for field data collection.

2.GIS (Geographic Information System) software: Unlike GPS, a GIS is used to
analyze and visualize spatial data. GIS software enables the combination of
different data types, examination of locations, and organization of information
into maps.

1. DEFINE CLEAR OBJECTIVES

2. SELECT DEVICES AND TOOLS

3. ASSIGN RESPONSIBILITIES

Clearly identify who will be responsible for data collection. 
Ensure that the staff tasked with data collection is qualified and trained. 
It’s ideal to include at least one person with GIS experience.
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4. GENERATE FIELD LOGS

For accurate data collection, ensure that conditions are optimal. 
Key factors to consider include:

Weather conditions: as heavy rain or fog can interfere with GPS accuracy.
Physical obstructions: such as trees or steep slopes can block GPS signals.
Plot accessibility: data collection may not be possible in hard-to-reach areas.

Whenever possible, avoid collecting data under unfavorable conditions to maintain
accuracy and reliability.

Ensure that all devices are configured correctly and fully charged before each field
visit to avoid interruptions during data collection. Verify that the GPS is set to WGS84
coordinates and configured to collect 6 decimal places.

5. ENSURE FAVORABLE CONDITIONS FOR DATA
CAPTURE

6. CHECK EQUIPMENT BEFORE EACH VISIT

We recommend to generate Field
logs to document the data
collection process: 

1.Names of responsible
individuals, 

2.Dates and hour, 
3.Locations (city or town) 
4.Tools and equipment used 
5.Observations during each

field visit.

This approach allows for
tracking the origin of the data
and verifying its accuracy. It
ensures that all parties
involved in the data collection
process can be identified,
making it easier to assign
responsibility and verify the
process.
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Go to the center 
of the plot

Wait for a good
GPS signal

GPS POINT DATA COLLECTION

For plots under 4 hectares, point or
polygon data can be collected for every
cultivated plot. 
If you choose to collect point data for
plots under 4ha that are not in a high-
risk areas, accepted formats include:
Excel, .csv, .kml, .shp, or GeoJSON. 

Required data includes: 
FLOID, 
Farmer ID, 
unique Farm unit ID, 
Plot Area, 
Latitude, 
Longitude, 
(Optional for 2nd or 3rd Grade SPOs)
Name of 1st Grade SPO. 

GOOD PRACTICES FOR POINT DATA COLLECTION

For each plot, a
geolocation point should

be collected at the center.

If a farm is large but the cultivated area
(the plot) is less than 4 hectares, do not
collect data for the entire farm. Instead,
record a single point at the center of the

cultivated area.

A farm can consist of several plots. 
A point should be collected for each plot

individually, rather than for the entire
property. Each of these plots must be

assigned with unique Farm Unit ID.

If there are barriers, such as rivers or
roads, dividing the farm, these should not
be considered as part of a continuous plot

but as separate plots. 

If two plots are next to each
other, avoid collecting points
that are too close to the edge.

HOW TO COLLECT POINT DATA

Add attributes

Go to the center of the
plot and find a location
free from obstacles,
such as trees, clouds,
or any physical
barriers that might
interfere with accurate
data capture.

Wait some minutes
until your device has a
strong GPS signal
before proceeding to
take the point.

Use the Farm Unit ID as
the primary key to identify
each plot. While multiple
plots can belong to the
same farm, each Farm
Unit ID must be unique to
a specific plot.
If your device allows it,
also include the Farmer ID
and plot area (in
hectares).
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2. Paste Link to 
Base Map and 

drag it to the map

An Attribute table contains information about each point or polygon. Each row
represents a point, line, or polygon, and each column holds details like name, size,
or type.

GPS POINT DATA PREPARATION
Once your point data has been collected, you will likely need to complete the required information attached to each
point, such as latitude and longitude, using a GIS tool. GIS software also helps verify and manipulate data points. There
are many GIS options available, and you can choose the one most suitable for your SPO. For the examples in this guide,
QGIS is used as a free option.

Set up your project to be in WGS84, and import a base
map.1. GENERAL CONFIGURATION

2. IMPORT YOUR FILE Import your point data file (e.g., KML, SHP, Excel).
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You can copy this link to connect to Google Satellite:
http://www.google.cn/maps/vt?lyrs=s@189&gl=cn&x={x}&y=
{y}&z={z}

Check the Attribute Table, here you can
identify which information can be used. 3. GENERAL CHECK OF THE FILE

You can copy this link to connect to Google Maps:
http://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}

To add kml, GeoJson and shapefile, Click Layer > Add
Layer >Add Vector Layer > Select th file.

1. Right-click XYZ
Tiles > New
Connection

2. Click three dots button
to select the file > Set x
field (longitude) and y

field (latitude) > Click Add
> Click Close

To zoom to the
points, Click on
Zoom Full

1. Right-click in the file >
Open attribute table 

1. Previously
save the

Excel (.xlsx) file
as .cvs,

then: Click
Layer >

Add Layer
>Add

Delimited Text



**In GIS, a layer is a collection of
information shown on a map, such as
points, lines, or areas like roads, cities,
or rivers In GIS, a layer is a collection of information shown on a map,

such as points, lines, or areas like roads, cities, or rivers.

Example of a shapefile document
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4. PREPARE THE FILE FOR EDITING

4.1 MAKE SURE THE FILE IS IN
SHAPEFILE FORMAT FOR EDITING

If you have all your points in one file, you may
need to export it as a shapefile if it is not
already in order to edit the points later.
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If you have several files like several KMLs, use a
tool in the GIS to merge them into a single file.4. 2 MERGE FILES

2. Click the three points
button on Input Layers >

Select the files to be
merge > Click Ok

This layer is editable but created as temporary by default. To preserve your work, export it
to a Shapefile to prevent the file loss.

1. Right-click in the file >
Export > Save feature as

1. Click Vector >
Data Management

Tools > Merge
Vector Layers

2. Select Format of file to
be exported (e.g.
Shapefile) > Set

Coordinate Reference
System (CRS) as WGS 84



Delete unnecessary columns by clicking on
Editing tool           and click on delete fields. 
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1. Install KML Tools
by: Click Plugins

>Manage and Install
Plugins

Once you have your file ready to edit it, rename
the fields and correct any names if necessary. 

For this example, “expand from tag: value pairs" was chosen
due a colon (:) is separating the title and the value
(e.gPlotArea: 0.9 and not PlotArea=0.9).

If you have one field in your attribute table that contains multiple useful
data (e.g., farmer ID and plot area) in the same field, you should use tools to
separate them.

4. 3 SEPARATE FIELDS

4. 4 RENAME FIELDS

This layer is editable but created as temporary by default. To
preserve your work, export it to a Shapefile to prevent the file
loss.

2. Click Vector >
KML Tools >

Expand HTML
description field

3. Select the file >
Choose an option in
How to Expand the

description field

2. Click Fields>
Change field

names

1. Right-click on
the file > Click
Properties
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Additionally, you can delete a point by clicking Select Features.

Deleted features with Deleted Selected. 
 
And Save Layer Edits to maintain changes.

If you missed any fields during data collection, you can add new
fields manually for FLOID, plot area, farmer ID.
Check for duplicates in your Farm_IDs, as these should be unique
and not repeated. 
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Zoom to the file to verify the location of the points. Ensure
they are correctly placed, especially within the same
country or corresponding city. 

5. IDENTIFY INCORRECTS
POINTS

Edit points that are not correctly located, or delete them if
they do not correspond to any farm. 6. EDIT POINTS

7. ADD MISSING FIELDS

1. Right-click on
the file > Click

Zoom to Layer

1. To view the editing tools
Click View > Toolbars >

Activate Digitizing toolbar
2. Click Toogle 

Editing

3. Click Vertex Tool or Click
on the Drop-down arrow >

choose Vertex Tool
(Current Layer)

4. Click on the point > Click
again to place it in the

correct position

3. On expression add
the formula or text to
applied to all the field

1. Click on
toggle tool

2. Click Open Field
Calculator

e.g. editing tool for crossed borders and to overlapped plots.
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In attributes, add a calculated field for
Latitude and Longitude:

$x for latitude,
$y for longitude.

8. ADD LATITUDE AND LONGITUDE
FIELDS

Export the data in a format accepted by Fairtrade International for
deforestation analysis. Make sure the format is compatible with Fairtrade
International requirements. The name should include:

organisation’s FLOID, 
country,
product (cocoa or coffee) for which you are submitting data. 

9. EXPORT DATA

Repeat all the steps to add a
new field for Latitude with
the expression $y.

(file name should specify
[FLOID]_[Country]_[Prod
uct].

1. Repeat steps from 1 to
3 from previous point 7.
Add missing fields

2. On expression
add $x to calculate

longitude

2. Select Format of file to be
exported (e.g. GeoJson) > Set
Coordinate Reference System

(CRS) as WGS 84

1. Right-click on the file >
Click Export > Save

feature as
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GOOD PRACTICES FOR POLYGONS

POLYGON DATA COLLECTION

Required for plots where the cultivated
area is 4 hectares or more or the plot is
in a known high-risk area. 

Polygon data should include: 
FLOID, 
Farmer ID, 
unique farm unit ID, 
(Optional for 2nd or 3rd Grade SPOs)
Name of 1st Grade SPO attached to
each polygon.

You can walk around the boundaries of the plot
to collect the data by activating tracking. 
When doing this, it is recommended to use a
handheld GPS unit or specialized field
equipment, rather than a cell tower devices
like smartphones or tablets. 
Once you’ve completed the polygon, save the
polygon and insert the Farm Unit ID in the
polygon name. 

If the plot is too large and difficult to walk
around, ideally, collect a point at each vertex.
Later, you can draw the polygon on the desktop
using a GIS.
You must stand in the first corner, save the
point, continue to each corner and collect
points in sequence. 
Save each point with Farm Unit ID as the main
identifier. If your device does not automatically
assign an order, add an identifier with the
point’s order (e.g., "1", "2", "3").  
It is recommended to follow a clockwise
direction. 
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Import the polygon/corner points file (e.g., KML, SHP, Excel). 2. IMPORT YOUR FILE

An Attribute table contains information about each point or
polygon. Each row represents a point, line, or polygon, and each
column holds details like name, size, or type.

Data Validation

Once your polygon or corner points have been collected, you will likely need to complete the required information
attached to each plot, such as corner points coordinates and total area, using a GIS tool. GIS software also helps verify
and refine polygon shapes or estimated boundaries for accuracy. There are many GIS options available, and you can
choose the one most suitable for your SPO. For the examples in this guide, QGIS is used as a free option.

GPS POLYGON DATA PREPARATION

1.GENERAL CONFIGURATION 

You can copy this link to connect to Google Satellite:
http://www.google.cn/maps/vt?lyrs=s@189&gl=cn&x={x}&y=
{y}&z={z}

You can copy this link to connect to Google Maps:
http://mt1.google.com/vt/lyrs=m&x={x}&y={y}&z={z}

3. GENERAL CHECK OF THE FILE Check the Attribute Table, here you can
identify which information can be used. 

1. Right-click XYZ
Tiles > New
Connection

To zoom to the
points, Click on
Zoom Full

1. Click Layer >
Add Layer>Add

Vector Layer
2. Click three dots button
to select the file >> Click

Add > Click Close

1. Right-click in the file >
Open attribute table 
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Set up your project to be in WGS84, and import a base map.

2. Paste Link to 
Base Map and 

drag it to the map
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This layer is editable but created as temporary by default. To
preserve your work, export it to a Shapefile to prevent the file
loss.

Toolbox

4. PREPARE THE FILE FOR EDITING

If you have all your points in one file, you may need to
export it as a shapefile if it is not already in order to edit
the points later.

4. 1 CHANGE THE FILE
FORMAT

If you have points at every corner of your plot,
you can connect them to form polygons.4. 2 CONNECT POINTS AND

CREATE POLYGONS

If you have lines that form the boundaries but are
not complete polygons, use a tool to convert
them into polygons.

4. 3 CONNECT LINES AND
CREATE POLYGONS

2. Select Format of file to be
exported (e.g. Shapefile) > Set
Coordinate Reference System

(CRS) as WGS 84

1. Right-click in the file > 
Export > Save feature as

1. To view the
Processing toolbox
Click Processing >

Toolbox

2. Look for Points to
Path > Double click to

open the tool

4. in Path group Expression 
select the field with the farm

identifier or Farm ID

3. Select the
file > In Order

Expression
select the

field
containing the

point
collection

order 

2. Select the file
> Click Run
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1. Click Vector >
Geometry Tools >
Lines to Polygon
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Delete unnecessary columns by clicking on
Editing tool           and click on delete fields. 
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If you have several files like several KMLs, use a
tool in the GIS to merge them into a single file.4. 4 MERGE FILES

Once you have your file ready to edit it, rename
fields and correct any names if necessary.4. 5 RENAME FIELDS

This layer is editable but created as temporary by default. To
preserve your work, export it to a Shapefile to prevent the file
loss.

If you cannot create polygons automatically, you can manually draw
the polygons by connecting the points you've collected and using
images or maps as a reference.

5. DRAW POLYGON

Click on            when done.

1. Click Vector >
Data Management

Tools > Merge
Vector Layers

2. Click the three points
button on Input Layers >

Select the files to be
merge > Click Ok

1. Right-click on the
file > Click Properties

3. Left-click on Editing
tool > Rename the

field Name and click
OK

2. Left-click on
Fields tab

1. Click on toggle
tool> Click add

polygon feature

3. Add field
information > click

OK

2. Draw the polygon
counterclockwise
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Edit the polygons that are incorrectly located or eliminate
them if they do not correspond to any farm.  

6. IDENTIFY AND EDIT INCORRECT POLYGONS

6.1 VERIFY THE LOCATION 

Edit the polygons that are incorrectly located or eliminate them if
they do not correspond to any farm.6.2 EDIT POLYGONS

6.3 CHECK POLYGON VALIDITY Check and modify polygons with errors in their shape,
fix boundaries that don't align, delete unnecessary
vertices, or correct irregular shapes.

Boundaries of polygons should be closed, meaning that the
start and end points of the polygon should meet.
Polygon sides should not cross or overlap each other and
ensure that polygons do not overlap with another plots. 

2. Click on the
polygon that

need to edited

3. Click on the
vertex tool

1. Click on the toggle
editing tool

1. Click on the vector
tab > click topology

checker

3. Select your file >
select the rules > click
on plus sign > click OK

4. Click on validate all
tool > check list of

errors

2. Click on  
configure tool
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4. Drag the vertices to
correct the shape

manually, save your edits
when done.

1. Right-click on the file
> left click on Zoom to

layer(s)
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8. EXPORT DATA

If you missed to collect any fields during field collection,
you can add new fields manually for FLOID, and Farmer lD.
Check for duplicates in your Farm IDs, as these should be
unique and not repeated.

7. ADD MISSING FIELDS

1. Click on toggle 
tool

2. Click Open 
Field Calculator

4. Add the value
click ok

3. Add field 
name

1. Right-click on the
file > Click Export >

Save feature as

2. Select the format
GeoJSON >

enter file name >
click OK
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Export the data in a format accepted by Fairtrade International for
deforestation analysis. Make sure the format is compatible with Fairtrade
International requirements. The name should include:

organisation’s FLOID, 
country,
product (cocoa or coffee) for which you are submitting data.

(file name should specify
[FLOID]_[Country]_[Prod
uct]
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While many steps have been covered throughout the data collection and editing process for
points and polygons, it's important to perform a final check to ensure that everything is in order.
Before submitting, make sure to follow the Data Quality Check  to verify that you have met all
requirements for submission.

DATA VALIDATION

KNOW MORE
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https://www.fairtrade.net/en/why-fairtrade/why-we-do-
it/deforestation/resources-for-producers-on-the-eu-deforestation-regulation.html

https://nextcloud.fairtrade.net/index.php/s/T9FF82xe25GF9Hs?path=%2FGuidance%20for%20SPOs%20and%20Traders%2FGuidance%20for%20SPOs%2FEnglish%2FSPO%20Guidance%20-%20short%20step-by-step%20version
https://nextcloud.fairtrade.net/index.php/s/T9FF82xe25GF9Hs?path=%2FGuidance%20for%20SPOs%20and%20Traders%2FGuidance%20for%20SPOs%2FEnglish%2FSPO%20Guidance%20-%20short%20step-by-step%20version
https://www.fairtrade.net/en/why-fairtrade/why-we-do-it/deforestation/resources-for-producers-on-the-eu-deforestation-regulation.html
https://www.fairtrade.net/en/why-fairtrade/why-we-do-it/deforestation/resources-for-producers-on-the-eu-deforestation-regulation.html

